Logo54.144.21.195 
  Home  News  Recent  Forums  Search  Contact
  Menu
 Username

 Password


   Register here

 Main menu
   View images
   BBCode test
 
 Content
   Statement of intent
   Terms Of Service
   IRC Channel
   List Content

 In cooperation with
  OS4Depot.net
  OpenAmiga.org
  OS4Welt

 Links
  AmigaOS4
  IntuitionBase
  UtilityBase
  Amiga Flame
  Amiga Spirit
  AmiKit
  Aminet
  AmiBay
  AmigaBounty
  AmigaWorld
  Exec
  Amiga.cz
  View comments
Title  
  Forums
    Software
      AmigaOS 4  
AlkaronProblems when booting OS4.1 *solved*20110308 22:39
Hi!

For a couple of weeks I have had some problems when booting up OS4.1. It is slow (as hell). It takes about 4 min. before workbench is useable. I've tried most thing, first thing is checking network-connection, as this is a very common thing that might delay. Its not the problem. I have tried disconnecting hardware, defraged the SFS2-partition etc, no luck.. I have run out of ideas.

http://www.youtube.com/watch?v=-6x1J1Qkmd8

Using OS4.1u2
Hardware: PEG2 G4
Navigate: 1-5 
ChrisHRe: Problems when booting OS4.120110308 23:43  #2768
@Alkaron
Does OS4 run slowly once it has booted? I assume not (otherwise it could be DMA vs PIO mode, or very low Max Transfer value, or any number of other "general" causes.).

My recommendation would be to disable all 3rd-party stuff that you can. That means disabling all WbStartup programs, and disabling User-Startup. If still no luck then move any 3rd-party Devs & Datatypes out of their folders (store them somewhere else temporarily), but if in doubt ask which ones come with OS4.

If that still doesn't help then you need to find exactly which point it is getting stuck. I suggest finding a Shell program that plays a BEEP noise (or similar), and placing it at 2 points in the Startup-Sequence. You can then hear (roughly) where the delay is happening (assuming it is in one place), and then gradually narrow 2 beeps closer & closer together, until you find the exact spot. Since you didn't report slow performance AFTER booting, I think it is very likely there is a particular command causing the problem.

P.S. The ONLY way to prove that the network connection is not the problem is by putting a semi-colon at the start of the C:AddNetInterface line in S:StartUp-Sequence. This disables networking.
TSKRe: Problems when booting OS4.120110309 00:44  #2770
@Alkaron

I bet it's corrupted ENVARC:ringhio.appsprefs.xml file. Check if that file is abnormally big or open it in any text editor and check if there's one strange character repeated millions of times then that file is corrupted. Just delete it and remember to delete also ENV:ringhio.appsprefs.xml.

All files in ENVARC: are copied into ENV: with every boot and if ENVARC: is full of big files it will slow booting down.
AlkaronRe: Problems when booting OS4.120110309 07:22  #2773
@TSK

Yep! Thats the one. It seems to be corrupted. A single character is repeated over and over..

ringhio.appsprefs.xml 3273909 ----rwed 23-Feb-11 12:41:24

Deleting and rebooting right now..

Yes! ..

Big difference.. Thank you very much TSK..
ChrisHRe: Problems when booting OS4.120110309 10:11  #2778
@Alkaron
Shame that you could not send a copy of the corrupt file to Rigo :(
TSKRe: Problems when booting OS4.120110309 11:47  #2780
@ChrisH

I think Rigo have said it's fixed already (in beta/next update).
Navigate: 1-5 
Home
Snack! forum website engine, Created in 2008 by Björn Hagström