Logo54.224.162.138 
  Home  News  Recent  Forums  Search  Contact
  Menu
 Username

 Password


   Register here

 Main menu
   View images
   BBCode test
 
 Content
   Statement of intent
   Terms Of Service
   IRC Channel
   List Content

 In cooperation with
  OS4Depot.net
  OpenAmiga.org
  OS4Welt

 Links
  AmigaOS4
  IntuitionBase
  UtilityBase
  Amiga Flame
  Amiga Spirit
  AmiKit
  Aminet
  AmiBay
  AmigaBounty
  AmigaWorld
  Exec
  Amiga.cz
  View comments
Title  
  Forums
    Hardware
      AmigaOS 4  
amigo1Sam440 flex 800MHz install problems20110317 09:47
Hi folks,

I had a HD crash, now I'm trying to reinstall the system on a new HD. Without success.
I posted this on AW and here on Amigans I hijacked my own thread about a JXF4 glitch; so bettter to start a new one instead, on AW i'll do the same.
Probably and hopefully the problem can be solved without having to bother ACube.

It's a Sam440Flex 800, 1GB, Radeon 9250 preinstalled system, apart from a new DVD and new HD nothing has been changed.

These are the problems so far:

- The original OS4.1 CD hangs at the boot image.
- The Update 1 CD hangs while loading Localization during the install (Welcome to the AmigaOS4.1 installation) waited 10 minutes after giving up, ca 7 minutes the subsequent times.
- If I go straight to the installation of the OS (HD and partitions are set up)
- the then newly installed system does not work right:
- it starts by the os jingle sound slowing down and crackling.
- Prefs/Locale does not start, after a while it freezes the mouse pointer and everything else.
- AmiDock is not closing a subdocky if I re-click on it's icon.

What I have done so far:

- I had UBoot 1.3.1c installed and since the above problems arose, I thought to update to v1.3.1d (successfully it said) but the above misbehaving are still there.

I'm not sure about flashing the PCIUpdate. Since it's not reversible, and I would like to know if the memory performance on 800MZh boards is decreasing the same 20% as for the 733MHz motherboards as explained on the Read Me PDF attached to the PCUpdate tool.

-I downloaded the OS4.1 Update 1 ISO from Hyperions website trice, it would help if Hyperion could mention a md5 or sha1 checksum on the download page couse I'm still not sure if the .iso file is ok.
(MAYBE SOLVED: nbache hint that LHA would complain if the downloaded file was corrupt)
- I burned the OS4.1u1 (For Sam440) CD 4 times (on 2 distinct computers, and 3 times on new different media)
- burned once again on DVD-RW media instead of CD media
- plugged a different HD
- tried a different PSU (PicoPSU 120W originally to 400 Watt CoolerMaster, spare almost new)
- dug out the original HD the system was shipped with and plugged in that. (unfortunately I erased it some time back, dumb me!)
- a) following a suggestion I unplugged the HD and tried to load from CD
- b) UBoot could not find any suitable SLB.
- c) Plugged the DVD-writer into sata port 0 (J20), it was plugged into port 3 (J23)
- d) and left the HD unplugged
- e) now it loaded both CDs but still blocking OS4.1 and still blocking on the "Welcome to the AmigaOS 4.1(u1) installation CD"-screen after clicking localization
- plugged in the harddrive again
- made sure HD is Sata1 instead of Sata2
- tried one new Sata cable on the DVD and the same new on HD
- Plugged to a 400W Cooler Master PSU and tried to load the OS off the 4 media
- plugged the PicoPSU back in again
- Started from CD again and noticed the system does not really hang, if I push the CD eject button it comes up with multiple requesters. I can not really tell about what it is complaining, since the requester window is to narrow and the title is cut off at the first letter of the the complaing process: "D" ,"L" (might be Locale) and "No disk in ENV" (this is because I ejected the CD I suppose). I can now insert the CD again and wait forever or press the eject putton again..did it 5 times randomly clicking "cancel" or "retry" then got bored.
- checked UBoot settings:
autostart=yes
baudrate=115200
boot_config=default
boot_method=boota
boot1=s4siicdrom
boot2=s4sii
boot3=
boota_timeout=3
bootargs=
bootcmd=menu; run menuboot_cmd
bootdelay=-1
eth1addr=00:50:C2:80:D1:3B
ethact=ppc_4xx_eth0
ethaddr=00:50:C2:80:D1:3A
ide_cd_timeout=20
ide_doreset=on
ide_reset_timeout=10
ipaddr=
limit_memory=1024
loads_echo=1
menuboot_cmd=
menuboot_cmd=boota
menuboot_delay=4
menucmd=loadmenu
os4_commandline=debuglevel=0
s4sii_maxbus=1
serverip=
sii3114ide_xfer=GG0G
stdin=usbkbd
stdout=vga
UBoot.txt
use_memory_limit=yes
video_activate=pci

- Took out one RAM module (antistatic precaution taken)
- test
- Put the above module to the 2nd socket
- test
- Same 2 test with the previously left out RAM moudle
- made a test with PPC-Memtest.lha (Aminet) test said ok
- made the same test with swapped modules, test ok, but 2 lines had white fonts, documentation does not mention it.
- now testing with memtester.lzx

Any help REALLY very appreciated since I don't now how to go further...SOB.

edit:
there are 3 HDs in total: 1) the crashed one, discard this one 2) a new one exact same model as the crashed one, but different manufacturing date(Hitachi 2,5" 160GB) 3) the one which originally came with the pre-build system. 160GB 3.5" (which I dumbly erased one month ago, so the original 4.1 system is not there anymore)
Navigate: 1-3 
ChrisHRe: Sam440 flex 800MHz install problems20110317 10:20  #2932
@amigo1
Don't have time to read it all now, but it sounds suspiciously like some kind of hardware problem (or incompatibility with your new HD). So:

Have you tried using a different HD? (Sounds like your "original HD" was not the one which crashed?)

Are you using different SATA cables to before? If yes, then try old ones. If no, then DO try new ones! (SATA cables can go bad)

Make sure HD & CD drives are plugged into the correct ports (as specified in the manual).

Maybe worth setting sii3114ide_xfer to 0000, although this should not be necessary.

And, of course, do not have anything (else) connected which you do not need, especially USB related.
amigo1Re: Sam440 flex 800MHz install problems20110317 10:45  #2934
@ChrisH

no, the one that crashed was not the original one. In total there are 3 HD:
1) crashed one 160GB 2,5
2) new one 160GB 2,5 (same model different manufacturing date)
3) original 160GB 3,5
4) 4th one but not accessible ATM 32GB SSD

- Everything else is disconnected apart USB Keyboard and Mouse, even the internal USB header cables.
- I have 3 SATA cables, 2 "old" ones 1 new one. (and they can really go bad by just being connected and not moved around? Gee, I guess there is a need to introduce a "best consume before xy" date on computer components..)
- The DVD drive and HD where firstly connected to the ports specified in the manual (HD to J20, DVD to J23). I followed a tip from a AW user to disconnect the HD for testing purposes, but in order for UBoot to be able to boot with only one device attached, I had to plug the DVD to J20, else it complained about no SLB found (weird).

I'll try the xfer setting as soon as teh memory test is finished.
fairdinkemRe: Sam440 flex 800MHz install problems20110317 12:38  #2937
@amigo1

I know this may sound weird it did to me but I had a very similar issue and I have been through all the same type of trouble shooting you have but this is what solved my problem so I suggest you humour yourself and give it a go.

My system was a Sam 440ep flex 733mhz 9250 128mb yada yada yada.........

Remove your graphics card and move it to the middle or bottom slot....... Yes you heard me right it's weird I know but it worked, change the graphics card to the middle or bottom slot so it is out of the the top fast slot to one of the slower slots and try installing AmigaOS4.1.1.

Acube said to me after informing them of my solution that some ATI cards they haven't tested may perform non standard PCI functions which may make them incompatible with the fast slot protocols or something to that effect.

Good luck

Navigate: 1-3 
Home
Snack! forum website engine, Created in 2008 by Björn Hagström