Logo54.196.17.193 
  Home  News  Recent  Forums  Search  Contact
  Menu
 Username

 Password


   Register here

 Main menu
   View images
   BBCode test
 
 Content
   Statement of intent
   Terms Of Service
   IRC Channel
   List Content

 In cooperation with
  OS4Depot.net
  OpenAmiga.org
  OS4Welt

 Links
  AmigaOS4
  IntuitionBase
  UtilityBase
  Amiga Flame
  Amiga Spirit
  AmiKit
  Aminet
  AmiBay
  AmigaBounty
  AmigaWorld
  Exec
  Amiga.cz
  View comments
Title  
  Forums
    Software
      AmigaOS 4  
Navigate: 1-20 21-40 41-60 61-80 81-100 101-120 121-140 141-160 161-180 181-200 201-220 221-238 
swoopRe: Qt Native News20110303 16:07  #2611
@orgin

Shouldn't it be "url=" at the beginning?
orginRe: Qt Native News20110303 16:17  #2612
@swoop

Only if you want to specify an alternative text for the link. Check the "BBCode test" link in the left menu.
joeledRe: Qt Native News20110303 16:49  #2616
@joeled

You wrote the same thing to me in another thread.
TSKRe: Qt Native News20110303 16:51  #2617
@alfkil

examples/animation/animatedtiles: parent process tries to exit before its child processes and it doesn't ever exit back to Shell.

If I try to launch a program with full path instead of filename only then it asks to insert volume with that whole path in Unix style plus volume name added to the end of the path in Amiga style, for example: /T2/qt-amigaos4-user-4.7/examples/network/T2: (where T2: is the volume name).
TSKRe: Qt Native News20110303 16:54  #2618
@Ricossa

When it asks to assign .config: assign it to RAM Disk:. Btw. Did you remember to do "assign sobjs: qt:lib ADD" also (after assign qt: blaablaa) (in case you don't have this in User-startup or didn't reboot to make that command executed).
elwoodRe: Qt Native News20110303 21:43  #2640
@alfkil

Please if you do new minigl libs update the version to avoid mistakes. You can release a 2.5.1. Thanks.
RicossaRe: Qt Native News20110304 06:28  #2651
@TSK

> Did you remember to do "assign sobjs: qt:lib ADD"

yes
RicossaRe: Qt Native News20110304 06:30  #2652
@kas1e

> Did you try with minigl2.5, or with minigl from qt-archive ?

I tried with your archives

> And did you have fontconfig caches in system:fonts or not ?

yes
kas1eRe: Qt Native News20110304 09:16  #2653
@Ricossa

Try without opengl libs from archive, but with 2.5 version which are on os4depot (in my case, with those minigl libs from archive, i have everything slowdowns a lot, and the same cpu 100%)
alfkilRe: Qt Native News20110305 21:16  #2674
@Ricossa

Also try setting QT_HOME to "/ram"

alfkilRe: Qt Native News20110305 21:27  #2675
@TSK

examples/animation/animatedtiles: parent process tries to exit before its child processes and it doesn't ever exit back to Shell.


Yeah, I know about this, I also know why it happens but not how to fix it. I will try, though...

If I try to launch a program with full path instead of filename only then it asks to insert volume with that whole path in Unix style plus volume name added to the end of the path in Amiga style, for example: /T2/qt-amigaos4-user-4.7/examples/network/T2: (where T2: is the volume name).


Huh, strange. I will look at this also, but it is not my first priority ;-).

Anyone besides TSK and kas1e who has it working?? Or anyone besides Ricasso who has problems?? All feedback is greatly appreciated! :-)

@kas1e and TSK

Have you tried the mainwindows examples? I really want to know, if they work!
chrisRe: Qt Native News20110305 21:42  #2676
@alfkil

Anyone besides TSK and kas1e who has it working??


Yep, just been testing it :) This is AWESOME, well done!

mainwindows/application seems to work fine, didn't try the other mainwindows ones yet.

Minor complaints:
1. QT seems to suck away all my graphics memory (it releases it on exit correctly). I don't know if this is something you can fix, or just a consequence of using minigl. It does seem a lot heavier than it should be.

2. The file requesters need a bit of work as they are geared for UNIX paths. If there is a single entry point perhaps you can just replace them with ASL?

3. As already said, the menus suck.

Oh, and the cute tetris clone ignores my keypresses, as does the stickman.
capRe: Qt Native News20110305 21:44  #2677
@alfkil
Ok heres my input.

I`ve tried it and failed like Ricossa.

Basically i`ve downloaded it. Unarchived,put the assigns in the user startup,rebooted then tried it.
I get complaints of not finding .so files. So i copy the files present in the directory to SYS:SObjs and still get the complaints.

Then deleted whole program till i see a solution.Drastic i know. The folder is lacking some minor instructions for installing as far as i can see.
alfkilRe: Qt Native News20110306 17:50  #2691
@cap

Which .so's does it complain about? Have you installed openssl from os4depot?

Also, how much gfxmem do you have?
alfkilRe: Qt Native News20110306 23:08  #2701
@chris

Oh, and the cute tetris clone ignores my keypresses, as does the stickman.


Not if you hover the mouse over the gaming area ;-)
chrisRe: Qt Native News20110306 23:24  #2702
@alfkil

Actually it looks like hovering isn't enough, you need to click on the gaming area. How odd. However now I know that, it seems to work perfectly :)
capRe: Qt Native News20110307 08:10  #2703
@alfkil

That was the problem so far. Openssl .so files -4 of them i copied.

Assign to ram as i went along.
Tried the files. No crashes.It seems i`m missing some fonts as well perhaps as what was displayed left a lot to be desired.
As for graphics ram I have a radeon 9250 256mb.
cha05e90Re: Qt Native News20110307 10:41  #2707
Only did some quick tests - and I am deeply impressed! No crashes and the stuff I started worked as expected (with some minor flaws which Alfkil already pointed out in his readme). But of course - even on my PegasosII 1GHz - this renders our minigl into the red zone. Hopefully we will have a real HW accelerated, full GL implementation one day...


TroelsRe: Qt Native News20110308 09:46  #2742
@All

A little off-topic Digia has acquired Qt commercial licensing business from Nokia: http://www.digia.com/C2256FEF0043E9C1/0/405002251
alfkilRe: Qt Native News20110308 15:56  #2748
@cap

It seems i`m missing some fonts as well perhaps as what was displayed left a lot to be desired.


Strange... Are you sure you have minigl properly installed? Can you maybe post a screenshot of it?
Navigate: 1-20 21-40 41-60 61-80 81-100 101-120 121-140 141-160 161-180 181-200 201-220 221-238 
Home
Snack! forum website engine, Created in 2008 by Björn Hagström