Logo54.162.91.86 
  Home  News  Recent  Forums  Search  Contact
  Menu
 Username

 Password


   Register here

 Main menu
   View images
   BBCode test
 
 Content
   Statement of intent
   Terms Of Service
   IRC Channel
   List Content

 In cooperation with
  OS4Depot.net
  OpenAmiga.org
  OS4Welt

 Links
  AmigaOS4
  IntuitionBase
  UtilityBase
  Amiga Flame
  Amiga Spirit
  AmiKit
  Aminet
  AmiBay
  AmigaBounty
  AmigaWorld
  Exec
  Amiga.cz
  View comments
Title  
  Forums
    Software
      AmigaOS 4  
eliyahuGLquake on OS420110112 17:53
folks,

i originally posted this over on amigaworld, but i don't think anyone saw it. maybe someone here can help with GLquake on OS4 systems?

i've been trying to get GLquake OS4 running on my SAM now for some time, but no matter what i do, i always end up with the same 'Hunk_Alloc: failed on 1544814608 bytes' error. i'd very much like to find a solution if there is one. here is my system info:

SAM440ep-flex @ 667MHz
radeon 9250 (128MB)
AmigaOS 4.1u2 with current minigl, etc.
original ID quake files from v1.09

when grabbing a log using the -stdout flag, here is what i get:

Added packfile Work:Games/Quake/id1/pak0.pak (339 files)
Added packfile Work:Games/Quake/id1/pak1.pak (85 files)
PackFile: Work:Games/Quake/id1/pak1.pak : gfx/pop.lmp
Playing registered version.
PackFile: Work:Games/Quake/id1/pak0.pak : gfx.wad
Console initialized.
bsdsocket.library V4 TCP/IP
Exe: 22:55:57 Jun 14 2005
128.0 megabyte heap
PackFile: Work:Games/Quake/id1/pak0.pak : gfx/palette.lmp
PackFile: Work:Games/Quake/id1/pak0.pak : gfx/colormap.lmp
Sound Initialization
CD Audio Initialized
Calling MGLInit...
Setting Vertex Buffer Size to 16000...
Window mode ON
Creating context...
Switching sync...
GL_VENDOR: The MiniGL Team
GL_RENDERER: MiniGL/Warp3D
GL_VERSION: 1.3
GL_EXTENSIONS: GL_MGL_packed_pixels GL_EXT_packed_pixels GL_EXT_bgra GL_EXT_color_table GL_EXT_vertex_array GL_EXT_compiled_vertex_arrays GL_NV_texgen_reflection GL_ARB_multitexture GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_add GL_EXT_texture_env_add
Multitexture extensions found.
FindFile: Work:Games/Quake/id1/glquake/15to8.pal
Video mode 320x240 initialized.
PackFile: Work:Games/Quake/id1/pak0.pak : gfx/conback.lmp
========Quake Initialized=========
PackFile: Work:Games/Quake/id1/pak0.pak : quake.rc
execing quake.rc
PackFile: Work:Games/Quake/id1/pak0.pak : default.cfg
execing default.cfg
Unknown command "volume"
FindFile: Work:Games/Quake/id1/config.cfg
execing config.cfg
FindFile: can't find autoexec.cfg
couldn't exec autoexec.cfg
3 demo(s) in loop
Playing demo from demo1.dem.
PackFile: Work:Games/Quake/id1/pak0.pak : demo1.dem

the Necropolis
PackFile: Work:Games/Quake/id1/pak0.pak : maps/e1m3.bsp
PackFile: Work:Games/Quake/id1/pak0.pak : progs/player.mdl
FindFile: Work:Games/Quake/id1/glquake/player.ms2
I_Error: Hunk_Alloc: failed on 1544814608 bytes
disconnecting from server...

i've tried specifying memory using the -mem flag all the way from 32MB to 128MB. running in window mode or full screen makes no difference. running with the -nosound flag makes no difference.

any ideas? has anyone gotten this to work on a SAM?

-- eliyahu

Navigate: 1-14 
nubechecorreRe: GLquake on OS420110112 18:07  #933
I have a sam too and i have no problem with glquake..

i use this syntax to run the game:

glqauke_aos4 -nomtex and it runs fine..

-nomtex means no multitexture support, but about your problem it seems that for some reason it doesn't work with your PAK files.. try a different PAK.. who knows maybe it works..

Last thing you can try before running glquake is to use the command stack 1000000

Sorry no much help..
nubechecorreRe: GLquake on OS420110112 18:07  #934
I have a sam too and i have no problem with glquake..

i use this syntax to run the game:

glqauke_aos4 -nomtex and it runs fine..

-nomtex means no multitexture support, but about your problem it seems that for some reason it doesn't work with your PAK files.. try a different PAK.. who knows maybe it works..

Last thing you can try before running glquake is to use the command stack 1000000

Sorry no much help..
TiredOfLifeRe: GLquake on OS420110112 19:59  #937
@eliyahu

Tried this version on a Sam440EP and all works fine.
There is another Quake port that I use available on OSDepot.
Have you tried that?
eliyahuRe: GLquake on OS420110112 21:04  #939
@TiredOfLife

the OS4 port of quake (using software rendering) works well. i also use capehill's quake2 port, and that works fine too. it's just GLquake that doesn't work.

oh well.

i wonder if the .pak files i have are either newer or older than the ones expected by GLquake.

-- eliyahu

nexusRe: GLquake on OS420110113 07:19  #945
@eliyahu

On my Sam440ep, glquake.aos4 also works fine with the pak-files from the 68k-clickboom-quake CD. However, there are problems with glquake. For example, the must-have quake add-on "Malice" does not work with glquake.aos4 (-> not-ignorable GrimReaper appears). However, Malice works fine with glquake.WOS on AOS3.9 or with non-gl quake.os4 (but Malice includes some hidden levels which only can be played with a gl-version of quake).


regards,
nexus
ChrisHRe: GLquake on OS420110113 20:32  #965
@eliyahu
TBH, I wouldn't bother with GLQuake, as it runs really crappily on my Sam440. The software rendered version runs much better! Although someone is supposedly working on a new OpenGL port of Quake 1, so fingers crossed that runs better.
TiredOfLifeRe: GLquake on OS420110114 00:08  #973
@ChrisH

Only had a quick look at the GL version but it seems to run pretty well here.
Can you elaborate a bit?

Cheers

ChrisHRe: GLquake on OS420110114 09:33  #979
@TiredOfLife
Has a frame rate a lot worse than the software rendered version (maybe under 10 fps from memory), and also the shadows looks really strange.
Cool_amigaNRe: GLquake on OS420110114 10:42  #981
Quake from Capehill's port runs very good and stable here (SamEp440667Mhz). I have tweaked the cfg and receive excellent frame rates on 640x480 without losing any graphical quality. At least, it behaves as the original on a low end pc.

Still if anyone wants to really enjoy the game, I strongly suggest using the Dark Places engine and the new Textures or the Ultra Pack on any old/cheap PC.

Btw, imo, we should forget QuakeGL and perhaps start porting Dark Places. It is OpenGL engine re-implementation of Quake's engine. I do have knowledge of the engine but I don't have the time nor knowledge of mGL on OS4.x (plus I am fairly sure that it won't run as good as I want on the low end machines but it could look good on X1000 as a demo on its launch). What everyone thinks about it?
kas1eRe: GLquake on OS420110114 12:39  #982
@Cool_amigaN

Port of DarkPlaces by HunoPPC in progress: youtube video
Cool_amigaNRe: GLquake on OS420110114 13:12  #983
@kas1e

Oh my! This is absolutely great! Dark Places is a must for Quake fans. We are talking for the best engine out there with which you can mod the game's guts inside out. New textures, paks etc. No need for anyone to work on QGL port :)

OTOH, Dark Places should be released with new version of drivers because judging from the video, we are going to face the same bottleneck as the FS2Open port when modded.

Anyway, I have faith on HunoPPC's optimization skills :)
TiredOfLifeRe: GLquake on OS420110114 13:34  #985
@ChrisH

I didn't notice a slow frame rate at all.
Have you tried recently?
I'm wondering if this is something that was greatly improved by the recent fixes.

Didn't notice any issues with the shadows either.
Will have closer look tonight.

Cheers
ChrisHRe: GLquake on OS420110116 12:26  #1042
@TiredOfLife
It is particle effects (bullets, explosions, etc) that seem to kill it for me, otherwise runs reasonably smoothly. Lots of dark shadows in what looks like strange places to me, but maybe that is how it is suppose to look?
TiredOfLifeRe: GLquake on OS420110116 14:09  #1046
@ChrisH

Hadb't noticed that but then my eyesight isn't the best.
The one problem I did have was that there is no sound.
Not really looked into that too much as I had been using the other port and hadn't even tried the GL version, until I read this thread.
Navigate: 1-14 
Home
Snack! forum website engine, Created in 2008 by Björn Hagström